Thursday, December 22, 2016

W140: 1996 Mercedes S600 Coupe - ADS Diagnosis w/ HHT !

A little treat, have a 96 S600 coupe come in with an ADS system defaulted to full stiff as it has a failure somewhere in the system. Rather than plug in Xentry/DAS or my Autel Maxidas, I threw on an original Mercedes HHT (Hand Held Tester) for a quick and dirty diagnosis on the system! Video below!





Monday, December 12, 2016

AMG Week, Coming to a close

So AMG week consisted of 7 or so various AMG's from 85-2012, all of which were getting their winter maintenance in order so they have an uneventful spring.

Among these was a W210 E55 that needed it's rear wheel carrier bushings (metal clad bushing) done on both sides as it was skipping about on the highway and making some squeaking noises. Well, one side had completely welded it's bolt to the inner race of the bearing and I had to do some drastic cutting, heating, etc to get it free from the carrier/control arm. I even managed to break the ball free from it's shell....somehow.







Then an 07 E63 was in for an oil change and some previously diagnosed bad ball joints. Was certainly caught in time as this particular joint was about ready to just pop out of it's socket. 




That's all I really had time to take pictures / vids of as I was on a time crunch with life, among other things. Happy I essentially have nothing planned for the next week, so I can take it easy and take them as they come. 

Friday, December 2, 2016

W211: The Most Ridiculous Battery Drain Problem Ever, 2003 E320, P.3


Somewhat of an update:


I started running the car on my scanner and was checking the coding on every module that I had access to as I noticed the teleaid the day before. So I started getting into the central gateway, telecommunications modules, etc and disabling every module of knowing teleaid was installed on the car. 

As I was doing the coding/module shut down, etc I had my meter in place. AS SOON as I hit "OK" to send new coding to the telecommunications module, amperage dropped. It will now bounce between 23-25 mA and every few minutes have a spike to 1.5amps for a few seconds. 

Which is telling me I may have isolated the draw to the MOST system. I think I may have put in an order for some of the MOST bypass connectors, so I'll be removing the teleaid module from the system entirely. 

Right now, I sent the car off to see how it fairs in the real world. Fingers crossed.

W211: The Most Ridiculous Battery Drain Problem Ever, 2003 E320, P.2



I'll have time at the end of this coming week to see if I can isolate entire SAM modules from the system to see if there's any change. I went through some module coding when I had some spare time and found the teleaid wasn't disabled from the whole analog to digital ordeal in 2009 - I can only assume from this, that I should be going through all the modules and making sure they're coded properly. The car may be thinking it has components that it doesn't. Oh joy. 

After the car was driven for a bit, I pulled the codes and the car had a 9026 - M16/32 Heat Exhanger Shut Off motor had failed or lead had short circuit. I put my weekly order in with Mercedes and should have the new valve (211 832 0584) coming by Monday or Tuesday. At $36, it's a soft hit that MAY just solve the drain. 

One could only hope, would sure be nice to have a cheap fix for him.

Thursday, December 1, 2016

W211: The Most Ridiculous Battery Drain Problem Ever, 2003 E320, P.1

I suppose it's about time I started posting up some of the newer cars I work on, as some of the problems they have may help someone make decisions about moving from an older chassis MB to some of the relatively affordable in purchase newer chassis.

Alright, so with that....

I'm equipped to do anything, so let's see if we can get this one sorted - it's my younger brother's car.... a 2003 E320 (WDBUF65J53A150123) with a hair under 160k miles.

What it does

Battery drains close to dead overnight, needs a quick jump and it's fine for the day. The car had a red battery warning on when it was initially purchased. Two brand new batteries were put in along with much newer and updated battery control module. Red warning hasn't been back, all is well. BUT!!!

If you park the car, remove the key and just sit there without touching anything, there's a whining noise coming from the low center of the dash. The radio cassette/CD player (Audio 50, no nav) system occasionally makes a noise and no matter how long you leave things be, you will always be able to open and close the windows, move the seats, or turn the radio on. Essentially the car never seems to go into it's sleep mode.

Test

Per MB procedure for battery draw, every door was opened with all the door pins taped shut, the hood opened and latches activated shut, and trunk opened and activated shut. As far as the car knows, everythings closed. This let's me get to all 3 fuse boxes on the car, without the car's alarm going ballistic. With my meter between the (-) post and the BCM (battery control module), amp draw with the car not sleeping was around 4 amps and stayed there for about 2 minutes and would then drop. The car will CONSTANTLY fluctuate between 74mA and 1.97 amps. MB manual calls for 60mA being OK, though preferably being 40mA and under at rest. It will fluctuate consistently and evenly between the readings all withing a minute of the variants. Oh Joy.

Proceeding to pull every last fuse and relay in all the fuse boxes has no change on amp draw fluctuation. So there may be either a coding problem on the car from a previously replaced component, a module staying awake, shorting wire, etc... OH JOY...

I've also completely disconnected the alternator from the system, which has no change. Which is nice because the alternator looks to be a fairly recent replacement. Instrument cluster was also disconnected and isolated with no change on draw. OHHH JOYYYYYY.

What's been done

- Both Aux and Main batteries have been replaced with new
- New and updated BCM
- I believe the front SAM has been replaced at some point to chase the problem

Once my scanner get's through it software updates, I'm going to be running the codes and will have an update post with the fault list. I'm going to omit every low voltage oriented code, as those will set off multiple modules from the drain. Should be interesting to get this car sorted.

Sunday, November 27, 2016

WTB: W210 Rear Axle Puller / Installer Tools 210589014300

I'm looking for a peculiar tool set, that if you have available, I'd love to purchase!

Part # 210 589 0143 00 ( 210589014300)

Please get in touch with me if you have available! Thanks, Allen 




Wednesday, November 23, 2016

GMT400: 5.7 Vortec Intake Gasket Failure

It's gone now, but a few weeks ago I picked up a 98 GMC Yukon for a couple hundred bucks that was draining it's coolant into the oil. Figured what the heck, it's cheap enough - I'll do a quick top end rebuild and have a 4x4 to drive around in snow.

Well it wasn't the head gaskets, but the notorious plastic intake gasket failure that caused the milky oil. 227k miles on what seem to be original gaskets and terrible coolant.

The rest of the gasket that's far away from the coolant passages maintained it's integrity, but everything that was in relative contact with coolant, turned into mush. Haven't seen any pictures of this on the web, so here they are.

 
This is where these 5.7 Vortec motors have problems with intake gaskets.  



Can see where the gasket broke and had water seeping into the oil galley. Felpro makes a metal/rubber gasket set for these that is essentially invincible. Torque everything to spec and you have a bulletproof 5.7 Vortec.

Truck didn't overheat, no bubbling coolant, etc. So I was confident it wasn't a head gasket. Put everything together and no more coolant loss. Life is good.

Then I sold the truck. lol

Tuesday, November 22, 2016

W210: Daily Diesel Gets A New Cat

So I've essentially gotten fed up with the raspiness from the straight pipe that's in place of the factory cat system on the ole 97 E300. What I found was this stainless 2.5" in/out diesel cat from Magnaflow to use as a replacement. It'll be installed in the factory position and should hopefully rid the exhaust note of a loud and annoying rasp from 2500-3200rpm. I'll try taking a proper video of the exhaust note before this goes on.

I guess there's other benefits, like soot control and less smell..... but all I care about is the sound and this was cheaper than resonator options lol




Wednesday, November 9, 2016

W210: Daily Diesel, Random Stalling Solved!

So, a backstory:

My 97 E300 stalls while running normally. It can be on the highway at 70 or just sitting at idle, stalls are completely random. The engine just stops. I can try to restart it, but depending on the try, it will not immediately restart. The glow plug lamp with not light up while immediately trying to restart. With a couple tries, the lamp will light up and the car will start normally and function perfectly. 

I started with the typical, K40 replacement with new OEM MB: http://artisanexcite.blogspot.com/2016/08/w210-daily-diesel-k40-replacement.html

Problem persisted. After checking the entire engine bay thoroughly, I noticed the SOV was leaking a bit and I bought a replacement. Figured two birds, one stone at trying to solve this stall problem.

Here's what I got:

Can see the connector has had some fluids seeping though.

Anyway, NONE of that solved my stalling. It became so frequent that I stopped driving the car for a while. I went after it again today and while poking around with the engine running it died on me! Not knowing if I'd done it, or the car being random I waited for it to start and I did exactly what I was doing before........STALL.

EXCELLENT.

Here's a vid:




I took the cover off and low and behold I've found my problem!





It wasn't the K40 as I had said, but the connector I was poking! GO FIGURE.

For those looking at solving their random stalling, please direct yourself straight to the K40 relay. It's a power distribution relay for multiple systems. They go bad every so often and they're cheap to replace. In my instance, A wire to pin connection in the connector failed and was giving me intermittent problems.

Success is grand. 

Saturday, November 5, 2016

W124: M119 Swapped 95 E320 Wagon Start and Rev

Yes, you didn't misread the title. The Red Rectum, a M119 5.0 swapped E320 Wagon. Oh joy.



There's a good possibility of getting some decent pictures and more details on the car as it'll be for sale eventually.... Stay tuned. 

Thursday, October 20, 2016

W210: DailyDiesel Takes Over The West Part: Probably 3

I'm jumbling around a few days in these posts, I definitely wasn't on a photo documenting mission like I was on with the R129 trip - so I'm doing the best I can with these.

Continuing on from our departure from the Grand Canyon area, a goal was set to make it to Montrose, CO and hole up there for the night to make it back home by that Saturday.

Parting views of the Grand Canyon



Left the area and headed due north through Utah to hit 70, take that for a couple hours so we can get through to Grand Junction then side road it down to Montrose.


Some point through the trip we stopped in at the Navajo reservation for lunch.

We got the Navajo tacos.

ABSOLUTELY AMAZING.

Deserts are cool - I'm glad the entire time we were out there the temps never got up over 90.






Somewhere through here I had a lapse in pictures - we ended up in Grand Junction then shot over to Montrose.


Settled in at a hotel, took a 15 minute breather and the mission was on to find where we could go to check out the sunset.

I literally opened up google maps on my phone and looked for roads going up hills and whatnot. Ended up going to "high point" in Black Canyon National Park. About 30 mins of a hike straight to the top of what was apparently the highest point in the direct vicinity.

The views on one side were nice

The views on the other side were even nicer..

I didn't even know there was a national park 15 mins away from the hotel.



Honestly, the views were way more breathtaking than the Grand Canyon - far less people there as well.


Timing is everything I guess





With the night spent in Montrose, the next day was a trip to hole up somewhere in Colorado Springs. I think we ended up taking 50E from Montrose to ColSpr. The route snaked along the Arkansas River and some other water ways 




Stopped at the Blue Mesa Reservoir because it looked cool as heck driving near it. Did some fishing, but no catching.
 

After leaving that area, I started noticing it was harder to keep speed. Sure as heck a quick check of our elevation showed we were steadily climbing. Awesome - low gear and power through for the DailyDiesel.

With the blink of an eye (or many, because I couldn't believe them), we ended up at the Continental Divide / Monarch Pass. At this point, I think this was the highest this car as ever been.

Pretty sweet all around!

I managed to get like 500 mpg on my way down too.


So we got into Colorado Springs mid afternoon. I found a campground somewhere in Cheyenne National Park (I think) called Wye. Seemed like it was out in the middle of nowhere and figured there really wouldn't be anyone there, which is always nice. BOY did I underestimate the middle of nowhere. 14 miles of rocky, sandy, bouldery roads lay ahead of me. I stopped 7 miles in because I absolutely did not think the car would survive the trip to the end. Not only that, but I'd have to turn around to get back the next morning.

Made for a cool shot though!

Ended up staying in a hotel in Colorado Springs - first hotel I booked ended up being a nightmare. I LITERALLY had a prostitute come to my door, the parking lot was a buzz with activity,...there was a lot going on. So I called it quits, found another hotel 15 miles north that was like a godsend.

For anyone planning on making a trip somewhere out to Colorado Springs, DO NOT STAY at the Days Inn Colorado Springs Central location. The place is an absolute ghetto dump and the rooms literally smelled like feces. Literally a dump. I can't believe I managed to last 45 mins.........

So with that adventure of a night over, the next morning we met up with a couple buddies at the base of Pikes Peak.

Yes, Pikes Peak. DailyDiesel would attempt to do Pikes Peak. We were warned right at the gate that the summit may not be open as there were gusts up to 70mph.

I figured, great. I might have a tailwind helping me up the mounting.....

It was open. The car barely made it. 2nd gear, full throttle and a steady stream of gray/black smoke coming out the rear. I'm sure whoever was following me was NOT very appreciative of the car making their ride smell terrible. I don't care though, it's there fault for being slower than me.

Views were fairly spectacular.


I didn't take any pictures on the way up, but as I didn't have to do anything on the way down, I figured I might as well.

Well, with the 10-11 day trip coming to a close I had views like this to look forward to for the better part of Saturday for the return home. 


 So, in total I logged JUST under 5k miles on the DailyDiesel. It had absolutely no hiccups along the way, started every time, was consistent in fuel usage, made it up mountains where no NA diesel loaded to the brim should ever be, and most importantly got me back home. I did need to put those tires on, but I believe an entire rear suspension rebuild is in order. I'm noticing the rear skipping around on the highway and if one side hits a pothole or something. For now, she's getting her oil change and will be on light duty for a while

Thanks for reading, hope you enjoyed! 

Wednesday, October 19, 2016

W210: Daily Diesel Takes Over The West? Part Classic Center Visit

So, a trip out west isn't worth doing if you're not going to atleast stop in at the classic center, right? I was fully expecting some sort of dedicated road, etc to the place like some of the dealers have around here. Nope. Literally smack dab in the middle of some industrial park in Irvine. Guess it's good they house all these cars in a fairly inconspicuous area.

Walking in through the front doors felt like I was walking into a run of the mill dealership lobby...outside of what was actually IN that lobby.

Rally Pagoda anyone?


This driving light in place of the star gets me. Whoever thought of this literally picked my brain.


There was another racing car next to it, with the drivers list up on the roof. Granted this is a more modern build.
 

Still badass.


Evo 2 ya'll.


Evo 2 with some problems it seems. Not sure what's going on with every last one of these cars with seemingly left to rot in some sort of Evo hell and coming out freshly painted with problems and no mileage. This whole star situation on the trunk annoys me. Of the 3 Evo 2's I've seen in person, the one in the classic center was a hooptie. (sorry owner)


Storage


E60 Renntech built for and owned by Jerry Seinfeld.

I need this widebody.


Maybach Zeppelin


Maybach Zeppelin oil leak.

Transporter anyone?










Had to get a picture out front with the Dailydiesel - just wouldn't feel right to have traveled the better part of 2300 miles to not stop in quickly. Was definitely worth it.